查看: 206|回复: 0

[补丁] 易语言5.92升级包

[复制链接]
回帖奖励 3 金钱 回复本帖可获得 1 金钱奖励! 每人限 1 次

签到天数: 61 天

[LV.6]常住居民II

220

主题

229

帖子

590

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
590
发表于 2020-2-11 17:41:14 | 显示全部楼层 |阅读模式
游客,如果您要查看本帖隐藏内容请回复




注意:升级到最新版本后,有些第三方的插件可能不兼容导致易语言无法打开,在升级后启动易语言前将其删除即可。


5.92版相对5.9版更新内容:
    1. 支持条件编译,可以使用程序配置控制具体编译程序中的哪些部分,从而支持将同一易语言程序编译为所需要的不同版本;
        具体请见所提供的相关例程("samples\其它\条件编译.e")及核心库中新增命令"条件宏是否存在"/"程序->配置->编译条件"菜单功能处的注释;
    2. 工具条现在默认排列在同一行上;
    3. 修正了"交换变量"和"强制交换变量"在交换字节/短整数数组成员时的bug,并且增加了对数组型变量的直接交换支持,用作支持快速交换数组数据;
    4. 增加了"修正另存为"功能(Ctrl+Alt+S快捷键调用),用作修正某些编辑用信息缺失的易语言程序(该信息的缺失并不影响程序正常保存/载入/编译);
    5. 系统配置对话框中支持从文件中导入用户自定义程序清单;
    6. 系统配置对话框中新增了指定编译程序调试版本时所固定使用输出文件名的选项.

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
以实待人,非惟益人,益已尤人。
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表